WPP Open Platform

Incident Report for WPP Open

Resolved

We're happy to report that the system is back up and running smoothly! Thank you for your patience and understanding while we worked to resolve the issue.
Posted Sep 11, 2025 - 10:19 UTC

Investigating

P1: The WPP Open Platform is currently experiencing intermittent issues that may impact Platform functionality. Our team is actively investigating the root cause and working to restore full stability. We appreciate your patience as we work to resolve this.
Posted Sep 11, 2025 - 09:58 UTC
This incident affected: Open Platform (Platform Service).