We're happy to announce that the system is back online. We've made some improvements to enhance your experience.
Posted Aug 04, 2026 - 07:30 UTC
In progress
We're currently working on improvements. You may experience intermittent issues between 04:00 and 07:30 UTC. We know this is an inconvenience, and we appreciate your patience while we get things back up and running.
Posted Aug 04, 2026 - 04:00 UTC
Update
We will be working on improvements, and you may experience intermittent issues between 04:00 and 07:30 UTC whilst we add new features and improvements.
Posted Aug 04, 2026 - 02:33 UTC
Scheduled
We will be working on improvements, and you may experience intermittent issues between 04:00 and 07:30 UTC whilst we add new features and improvements.
Posted Aug 03, 2026 - 20:00 UTC
This scheduled maintenance affected: WPP Open Platform Services (Platform Service, Platform Login, Platform File Manager).