WPP Open Platform

Incident Report for WPP Open

Resolved

We're happy to report that the system is back up and running smoothly!  Thank you for your patience and understanding while we worked to resolve the issue.
Posted Jul 01, 2025 - 19:08 UTC

Monitoring

Good news! We've implemented the fix for the system and are currently monitoring to ensure everything is working as expected. We'll provide another update shortly to confirm full restoration of service.  Thank you for your continued patience.
Posted Jul 01, 2025 - 18:45 UTC

Update

We are continuing to work on a fix for this issue.
We expect the system to be fully back online by 06:45 PM UTC.
Thank you for your understanding.
Posted Jul 01, 2025 - 17:53 UTC

Identified

We've identified a solution to the issue affecting the Creative Studio applications functionality and are currently implementing it.
We expect the system to be fully back online by 05:45 PM UTC.
Thank you for your understanding.
Posted Jul 01, 2025 - 17:33 UTC

Investigating

The WPP Open Platform is experiencing an unplanned outage affecting some of the Creative Studio applications. Our team is working diligently to identify the root cause and implement a solution. Thank you for your patience.
Posted Jul 01, 2025 - 16:32 UTC
This incident affected: Open Platform (Platform Service, Platform Login, Marketplace, Home widgets, News, DevHub), Design System (Web portal), Developers Portal (Web portal), and API Dev Portal.