WPP Open Platform

Incident Report for WPP Open

Resolved

We're happy to report that Creative Studio is back up and running smoothly!  Thank you for your patience and understanding while we worked to resolve the issue.
Posted 6 days ago. Apr 02, 2025 - 16:38 UTC

Identified

We've identified a solution to the issue affecting Creative Studio and are currently implementing it.

We expect the system to be back online soon. Thank you for your continued patience.
Posted 6 days ago. Apr 02, 2025 - 16:04 UTC

Investigating

P2: WPP Open Platform is experiencing an unplanned outage affecting several Creative Studio tools. Our team is working diligently to identify the root cause and implement a solution. Thank you for your patience.
Posted 6 days ago. Apr 02, 2025 - 14:51 UTC
This incident affected: Open Platform (Platform Service, Platform Login, Marketplace, Home widgets, News, DevHub), Design System (Web portal), Developers Portal (Web portal), and API Dev Portal.